Archivo de la etiqueta: vulnerabilidad

Desbordamiento de búfer en VLC Media Player

Se ha descubierto una vulnerabilidad en el reproductor de archivos multimedia VLC 1.0.5 que podría ser aprovechada por un atacante remoto para ejecutar código arbitrario.
VLC Media Player es un completo reproductor multimedia que soporta un gran número de formatos, como pueden ser: MP3, MPEG, DIVX, VCD o DVD entre otros, así como varios protocolos de streaming. Además está disponible para un amplio número de plataformas distintas como Windows, Mac OS X y para varias distribuciones de Linux. VLC también puede ser utilizado como servidor en unicast o multicast, en IPv4 o IPv6, para una red de banda ancha y tiene disponible un plug-in para Firefox que permite ver algunos archivos Quicktime y Windows Media desde páginas web sin necesidad de utilizar los reproductores de Apple o Microsoft.
El problema reside en un desbordamiento de búfer en el tratamiento de URLs ftp:// con archivos M3U específicamente creadas. Esto puede ser explotado por atacantes remotos para lograr la ejecución de código y comprometer los sistemas afectados.
Se ve afectada la versión 1.0.5, la versión 1.1.0 no está afectada.
Anuncios

Vulnerabilidades en Cisco Content Services Switch

Una vez mas nuestra querida empresa Cisco ha anunciado la existencia de dos vulnerabilidades en los dispositivos Cisco Content Services Switches 11500, que pueden ser explotadas por un usuario malicioso para provocar una denegación de servicio o evitar restricciones de seguridad.
La vulnerabilidad de denegación de servicio (explotable remotamente) reside en el tratamiento de cabeceras HTTP con saltos de línea especialmente manipulados.
Otro problema permitiría saltar restricciones de seguridad mediante el uso de cabeceras HTTP especialmente manipuladas con el parámetro “ClientCert”.
Hasta el momento no se ha publicado ninguna actualización para corregir estos problemas.
Para mitigar el riesgo de las cabeceras con “ClientCert” se recomienda el uso del siguiente comando: ssl-server http-header prefix ”
Cisco CSS & ACE Certificate Spoofing and Header Manipulation
http://www.vsecurity.com/resources/advisory/20100702-1/

Desbordamiento de búfer en ActiveX de HP Operations Manager

Se ha confirmado la existencia de una vulnerabilidad en HP Operations Manager para Windows, que un atacante remoto podría emplear para comprometer los sistemas vulnerables. El software HP Operations Manager es la solución en el mercado de HP para la gestión de eventos distribuidos, sistemas y disponibilidad El problema reside en desbordamientos de búfer en los controles ActiveX “srcvw4.dll” y “srcvw32.dll” al procesar argumentos de gran lonitud pasados a los métodos “LoadFile()” o “SaveFile()”. Un atacante remoto podría aprovechar este problema para ejecutar código arbitrario si consigue engañar al usuario para que visite una página web específicamente creada.
Se ven afectadas las siguientes versiones: HP Operations Manager para Windows versión 8.10 (con srcvw4.dll versión 4.0.1.1 y anteriores) HP Operations Manager para Windows versión 8.16 (con srcvw4.dll versión 4.0.1.1 y anteriores) HP Operations Manager para Windows versión 7.5 (con srcvw32.dll versión 2.23.28 y anteriores)
Para HP Operations Manager 8.x se recomienda instalar OMW_00060 y actualizar a srcvw4.dll versión 4.0.1.2 Para HP Operations Manager 7.x se recomienda instalar OVOW_00279 y actualizar a srcvw32.dll versión 2.23.29 HP
Más información:
HPSBMA02491 SSRT100060 rev.1 – HP Operations Manager for Windows, Remote Execution of Arbitrary Code
HP Operations Manager <= v8.16 – (srcvw4.dll) LoadFile()/SaveFile() Remote Unicode Stack Overflow PoC

El filtro XSS de Internet Explorer 8 sigue siendo vulnerable

Los investigadores Eduardo Vela y David Lindsay han presentado, en el marco de la conferencia Black Hat Europa de este año, un nuevo método para ejecutar ataques de cross-site scripting a través de los filtros XSS de Internet Explorer 8.
Microsoft introdujo un mecanismo para filtrar ataques de cross-site scripting, concretamente los de “tipo 1” o no persistentes. Un cross-site scripting no persistente es la clase de ataque más común y extendida de este tipo de ataques.
El atacante manipula una URL insertando código malicioso que, de manera errónea, aprovechando una vulnerabilidad, el sitio web usará para generar una página que contendrá el código legítimo más el código introducido por el atacante. La víctima que “inadvertidamente” use la URL proporcionada por el atacante, enviará una petición hacia el servidor web y este “reflejará” el código de vuelta hacia el cliente donde es usado por el navegador como si fuese código legítimo. Es denominado no persistente ya que el servidor no almacena el código malicioso y es reflejado porqué en realidad es el mismo navegador el que va a enviar el ataque a través de la petición HTTP hacia el servidor web y éste de vuelta al navegador de la víctima. La idea general del filtro XSS de Internet Explorer, es observar la secuencia solicitud-respuesta entre navegador y sitio web. A grandes rasgos, modifica el código que se recibe del servidor antes de que sea interpretado por el navegador, si detecta que la página recibida contiene código sospechoso enviado en una de las solicitudes del navegador. Básicamente, evita “reflejar” el código malicioso. La base del mecanismo de neutralización de ataques del filtro es alterar el código malicioso. En caso de observar código sospechoso de vuelta al navegador, el filtro actúa antes de que se interprete la página, insertando o reemplazando caracteres en partes de ese código para impedir su ejecución transformándolo en código no válido. Ya en su momento se hizo público una vulnerabilidad que aprovechaba el filtro XSS para producir este tipo de ataques. Microsoft liberó un boletín (MS10-002) en el que se corregía la vulnerabilidad. Aun así, se encontraron nuevas formas para revertir el uso del filtro y Microsoft volvió a reforzarlo en un nuevo boletín (MS10-018). Lo que han mostrado los investigadores es que es no solo es posible evadir el filtro sino que sigue siendo posible efectuar ataques de cross-site scripting, incluso en sitios webs que no son vulnerables. Adicionalmente, el filtro también podría ser usado por el atacante para impedir la ejecución de scripts legítimos, posibilitando la evasión de mecanismos de seguridad propios del sitio web visitado. David Ross de Microsoft, ha confirmado que publicarán un parche hacia el mes de junio para prevenir este tipo de ataque.
 
Más información: Abusing IE8s XSS Filters [PDF]
Guidance on Internet Explorer XSS Filter

Actualización de seguridad para Adobe Reader y Acrobat

Tal y como anunciamos anteriormente Adobe ha publicado una actualización para corregir 15 vulnerabilidades en Adobe Reader y Acrobat en diferentes plataformas, que podrían permitir a un atacante tomar el control de los sistemas afectados. Las versiones afectadas son Adobe Reader 9.3.1 (y anteriores) para Windows, Macintosh y UNIX; Adobe Acrobat 9.3.1 (y anteriores) para Windows y Macintosh; y Adobe Reader 8.2.1 (y anteriores) y Adobe Acrobat 8.2.1 (y anteriores) para Windows y Macintosh. Las vulnerabilidades anunciadas son de diversa índole, desde cross-site scripting, varios problemas de denegación de servicio, de corrupción de memoria y de desbordamiento de búfer. Adobe recomienda a los usuarios de Reader y Acrobat la actualizaciones a las versiones recientemente publicadas empleando la opción de actualización automática de los productos o bien descargándolas desde la propia web de Adobe: http://www.adobe.com/downloads/
Opina sobre esta noticia:
Más información: Security update available for Adobe Reader and Acrobat

Vulnerabilidad en IBM WebSphere Portal

IBM ha anunciado la existencia de una vulnerabilidad en IBM WebSphere Portal versiones 6.1.0.2 y anteriores.
IBM WebSphere Portal ofrece una aplicación compuesta o infraestructura de “mashup” empresarial y las herramientas para crear soluciones basadas en SOA (Arquitectura Orientada a Servicios). WebSphere Portal contiene una amplia variedad de tecnologías destinadas a desarrollar y mantener portales B2C, B2B y B2E.
El problema se sabe que está relacionado con el proceso de login, sin embargo IBM no ha facilitado más detalles sobre el problema, por lo que se desconoce tanto el impacto como los posibles vectores de ataque. Se recomienda actualizar a IBM WebSphere Portal versión 6.1.0.3 Cumulative Fix 03: http://www.ibm.com/eserver/support/fixes/fixcentral/swgquickorder?apar=PM09968&productid=WebSphere%20Portal&brandid=5o
aplicar el APAR PM08667:
Opina sobre esta noticia:
Más información: PM08667:
LOGIN VULNERABILITY

Denegación de servicio en kadmind de MIT Kerberos

Se ha anunciado una vulnerabilidad remota de denegación de servicio en el demonio de administración de MIT Kerberos (kadmind) versiones krb5-1.5 hasta krb5-1.6.3.
El problema reside en versiones antiguas de MIT Kerberos krb5 (krb5-1.5 a la krb5-1.6.3) debido a la referencia a memoria liberada. Un usuario remoto y autenticado puede explotar este problema mediante el uso de una nueva versión del protocolo kadmin que el soportado por el servidor.
Se trata de una vulnerabilidad en la implementación de MIT krb5, y no del propio protocolo Kerberos. El problema no se presenta en versiones modernas de MIT krb5.
Se ha publicado una versión krb5-1.7 que corrige el problema y también un parche disponible en: http://web.mit.edu/kerberos/advisories/2010-003-patch.txt
Opina sobre esta noticia:
Más información: denial of service in kadmind in older krb5 releases