Archivo de la categoría: boletines

Firefox introduce una grave vulnerabilidad con sus últimos parches

El día 20 de julio Mozilla anunciaba la nueva versión 3.6.7 y 3.5.11 de su navegador, que corregía 15 vulnerabilidades en 14 boletines de seguridad diferentes. Tres días más tarde ya está disponible la versión 3.6.8 para solucionar una vulnerabilidad introducida al corregir las anteriores.
La versión 3.6.8 de Firefox se ha tenido que lanzar con cierta urgencia (solo tres días después de publicar la versión 3.6.7) para corregir una vulnerabilidad que permite la ejecución de código arbitrario. La solución introducida en la versión 3.6.7 para corregir un problema de manejo de plugins, introducía un fallo que, bajo ciertas circunstancias, podría producir un desbordamiento de memoria intermedia. Esto podría permitir la ejecución de código arbitrario.
Para solucionarlo han publicado la versión 3.6.8 y el boletín MFSA2010-48 describiendo el fallo. La versión 3.6.7 ha sido por tanto bastante efímera, aunque no es la primera vez que ocurre con el navegador. La versión 3.6.4 apareció el 22 de junio, y desde entonces en menos de un mes se han publicado varias subversiones.
En la versión 3.6.4 los desarrolladores añadieron cierta protección contra los “cuelgues” de algunos plugins, para que no hicieran que todo el navegador dejase de responder. Para ello añadieron un “timeout”: si el plugin no respondía en ese tiempo, Firefox tomaba el control terminando la tarea. Así se evitaba que el cuelgue arrastrase a todo el navegador.
Sin embargo se dieron cuenta de que el “timeout” introducido era muy corto. Solo 10 segundos. Algunos plugins, como Flash, pueden no responder durante ese tiempo en algunas máquinas sin que signifique que el complemento haya dejado de responder necesariamente. En muy pocos días, se produjo una “travesía” hasta la versión 3.6.6 para corregir ese fallo, y aumentar el “timeout” hasta unos 45 segundos.

Acceso a información sensible en IBM WebSphere Application Server

Se ha anunciado una vulnerabilidad en IBM WebSphere Application Server (versiones 6.x y 7.0), que podría permitir a un atacante la obtención de información sensible. IBM WebSphere Application Server (WAS) es el servidor de aplicaciones de software de la familia WebSphere de IBM. WAS puede funcionar con diferentes servidores web y sistemas operativos incluyendo Apache HTTP Server, Netscape Enterprise Server, Microsoft Internet Information Services (IIS), IBM HTTP Server en sistemas operativos AIX, Linux, Microsoft, Windows y Solaris. El problema reside en el Web Container cuando maneja nombres de más de 20 caracteres. Un atacante podría aprovechar esto para provocar que el servidor devuelva un archivo erróneo y conseguir acceder a archivos arbitrarios.

Para IBM WebSphere Application Server 7.0.x se recomienda instalar el Fix Pack 7.0.0.11 o APAR PM06111 Para IBM WebSphere Application Server 6.1.x se recomienda instalar el Fix Pack 6.1.0.31 o APAR PM06111 Para IBM WebSphere Application Server 6.0.x se recomienda instalar el Fix Pack 6.0.2.43 o APAR PM06111 
Más información:
Recommended fixes for WebSphere Application Server
WebSphere Application Server Web Container information disclosure
was-webcontainer-info-disclosure (58557)

SEGURIDADES Diversas vulnerabilidades en 3Com Intelligent Management Center (IMC)

Se han anunciado cuatro vulnerabilidades en 3Com Intelligent Management Center (IMC) versiones anteriores a la 3.3 SP2 (R2606P13), que podrían permitir a unatacante conseguir información sensible o evitar restricciones de seguridad.
El primero de los problemas se debe a errores de validación de entrada en el script “imc/report/DownloadReportSource” al procesar los parámetros “fileDir” y “fileName”. Un atacante podría emplear esto para descargar cualquier archivo mediante ataques de escalada de directorios.
La segunda vulnerabilidad se debe a errores al procesar los parámetros “javax.faces.ViewState” y “callCount”, o URLs introducidas por el usuario. Un atacante podría aprovechar este problema para construir ataques de cross-site scripting.
Un tercer fallo reside en la validación de accesos en los archivos “/imc/reportscript/sqlserver/deploypara.properties”, “/rpt/reportscript/sqlserver/deploypara.properties” y “/imc/reportscript/oracle/deploypara.properties”. Un atacante podría llegar a descubrir la contraseña de la cuenta “sa” de SQL a través de esta vulnerabilidad.
Por último, errores en la consola Axis2, podrían permitir a un atacante conseguir acceso administrativo no autorizado a la consola o conseguir información sensible.
Se recomienda actualizar a 3Com Intelligent Management Center (IMC) version 3.3 SP2 (R2606P13).
Más información:
Intelligent Management Center v3.3 SP2 (R2606P13)

PR10-01 Unauthenticated File Retrieval (traversal) within 3Com* iMC (Intelligent Management Center)

http://www.procheckup.com/vulnerability_manager/vulnerabilities/pr10-01


PR10-02 Various XSS and information disclosure flaws within 3Com* iMC (Intelligent Management Center)

PANTALLAZO AZUL Vulnerabilidad a través de Aero en Windows 7 y 2008 R2 (versiones de 64 bits)

Microsoft ha advertido sobre una vulnerabilidad que en realidad se hizo pública hace meses, y que afecta a Windows 7 y 2008 R2 en sus versiones de 64 bits. El fallo se puede aprovechar solo si el componente Aero está activo. La vulnerabilidad se ha descubierto a través del popular visor gratuito de imágenes Irfanview.
El fallo se encuentra en el renderizado de imágenes con la API GDI, en concreto en el componente Canonical Display Driver (cdd.dll). CDD emula una interfaz de Windows XP para que las aplicaciones accedan al motor de gráficos GDI. El fallo podría ser aprovechado por un atacante para causar una denegación de servicio y potencialmente ejecutar código arbitrario a través de una imagen especialmente manipulada que sea visitada con el navegador o vista con el visor por defecto. Aunque los vectores de ataque siguen siendo discutidos.
La ejecución de código es, en principio, teórica. Se trata de un problema de acceso desde la memoria del usuario a la memoria del kernel, lo que garantiza la posibilidad para un atacante de, al menos, provocar una denegación de servicio a través de un BSOD (Blue Screen Of Death o “pantallazo azul”). A partir de ahí, conseguir controlar el flujo de los registros de sistema para ejecutar código en el espacio del kernel (el más privilegiado) puede resultar complejo, en gran medida, por los nuevos sistemas de seguridad ASLR (Address Space Layout Randomisation) que incluyen los Windows desde su versión Vista. Existen fórmulas para eludir esta medida de seguridad (demostradas en el último concurso Pwn2Own), pero su explotación se hace mucho más compleja.
Además, el fallo solo funciona en las versiones de 64 bits (e Itanium) y, como hemos mencionado, Aero debe estar activo. Ni siquiera viene instalado por defecto en 2008. En Windows 7, por el contrario, aparece instalado y activo.
Por último, según el CVE (CVE-2009-3678) que le ha otorgado Microsoft a la vulnerabilidad, se deduce que fue encontrada en 2009. El popular visor gratuito Irfanview es el que aportó la pista. Sin estar todavía oficialmente programado para funcionar en Windows, se observó que al visualizar muchas miniaturas, el programa provocaba un BSOD en Windows 7 de 64 bits. Se pensó que el fallo era exclusivamnte de la aplicación y no del sistema operativo hasta que, varios meses después, parece que Microsoft reconoce el problema como propio.

Más información:

V4.25: bluescreen with Windows 7, cdd.dll / win32k.sys

Vulnerability in Canonical Display Driver Could Allow Remote Code Execution

Vulnerabilidades de ejecución de código en PostgreSQL

Se han anunciado diversos problemas en PostgreSQL (versiones 8.x y 7.4), que podrían permitir a un atacante evitar restricciones de seguridad o ejecutar código arbitrario.
PostgreSQL es una base de datos relacional “Open Source”, bastante popular en el mundo UNIX, junto a MySQL.
El primer problema se debe a errores en “Safe.pm” y “PL/Perl”; un atacante autenticado podría emplearlos para ejecutar código Perl en el servidor de base de datos si PL/Perl está instalado y activo.
La segunda vulnerabilidad reside en la asignación incorrecta de permisos en la tabla “pltcl_modules”, un usuario autenticado podría emplear este fallo para ejecutar código Tcl en el servidor si PL/Tcl está instalado y activo.
Se recomienda actualizar PostgreSQL a la versión 8.4.4, 8.3.11, 8.2.17,
8.1.21, 8.0.25 o 7.4.29 desde:

Desbordamiento de búfer en ActiveX de HP Operations Manager

Se ha confirmado la existencia de una vulnerabilidad en HP Operations Manager para Windows, que un atacante remoto podría emplear para comprometer los sistemas vulnerables. El software HP Operations Manager es la solución en el mercado de HP para la gestión de eventos distribuidos, sistemas y disponibilidad El problema reside en desbordamientos de búfer en los controles ActiveX “srcvw4.dll” y “srcvw32.dll” al procesar argumentos de gran lonitud pasados a los métodos “LoadFile()” o “SaveFile()”. Un atacante remoto podría aprovechar este problema para ejecutar código arbitrario si consigue engañar al usuario para que visite una página web específicamente creada.
Se ven afectadas las siguientes versiones: HP Operations Manager para Windows versión 8.10 (con srcvw4.dll versión 4.0.1.1 y anteriores) HP Operations Manager para Windows versión 8.16 (con srcvw4.dll versión 4.0.1.1 y anteriores) HP Operations Manager para Windows versión 7.5 (con srcvw32.dll versión 2.23.28 y anteriores)
Para HP Operations Manager 8.x se recomienda instalar OMW_00060 y actualizar a srcvw4.dll versión 4.0.1.2 Para HP Operations Manager 7.x se recomienda instalar OVOW_00279 y actualizar a srcvw32.dll versión 2.23.29 HP
Más información:
HPSBMA02491 SSRT100060 rev.1 – HP Operations Manager for Windows, Remote Execution of Arbitrary Code
HP Operations Manager <= v8.16 – (srcvw4.dll) LoadFile()/SaveFile() Remote Unicode Stack Overflow PoC

El filtro XSS de Internet Explorer 8 sigue siendo vulnerable

Los investigadores Eduardo Vela y David Lindsay han presentado, en el marco de la conferencia Black Hat Europa de este año, un nuevo método para ejecutar ataques de cross-site scripting a través de los filtros XSS de Internet Explorer 8.
Microsoft introdujo un mecanismo para filtrar ataques de cross-site scripting, concretamente los de “tipo 1” o no persistentes. Un cross-site scripting no persistente es la clase de ataque más común y extendida de este tipo de ataques.
El atacante manipula una URL insertando código malicioso que, de manera errónea, aprovechando una vulnerabilidad, el sitio web usará para generar una página que contendrá el código legítimo más el código introducido por el atacante. La víctima que “inadvertidamente” use la URL proporcionada por el atacante, enviará una petición hacia el servidor web y este “reflejará” el código de vuelta hacia el cliente donde es usado por el navegador como si fuese código legítimo. Es denominado no persistente ya que el servidor no almacena el código malicioso y es reflejado porqué en realidad es el mismo navegador el que va a enviar el ataque a través de la petición HTTP hacia el servidor web y éste de vuelta al navegador de la víctima. La idea general del filtro XSS de Internet Explorer, es observar la secuencia solicitud-respuesta entre navegador y sitio web. A grandes rasgos, modifica el código que se recibe del servidor antes de que sea interpretado por el navegador, si detecta que la página recibida contiene código sospechoso enviado en una de las solicitudes del navegador. Básicamente, evita “reflejar” el código malicioso. La base del mecanismo de neutralización de ataques del filtro es alterar el código malicioso. En caso de observar código sospechoso de vuelta al navegador, el filtro actúa antes de que se interprete la página, insertando o reemplazando caracteres en partes de ese código para impedir su ejecución transformándolo en código no válido. Ya en su momento se hizo público una vulnerabilidad que aprovechaba el filtro XSS para producir este tipo de ataques. Microsoft liberó un boletín (MS10-002) en el que se corregía la vulnerabilidad. Aun así, se encontraron nuevas formas para revertir el uso del filtro y Microsoft volvió a reforzarlo en un nuevo boletín (MS10-018). Lo que han mostrado los investigadores es que es no solo es posible evadir el filtro sino que sigue siendo posible efectuar ataques de cross-site scripting, incluso en sitios webs que no son vulnerables. Adicionalmente, el filtro también podría ser usado por el atacante para impedir la ejecución de scripts legítimos, posibilitando la evasión de mecanismos de seguridad propios del sitio web visitado. David Ross de Microsoft, ha confirmado que publicarán un parche hacia el mes de junio para prevenir este tipo de ataque.
 
Más información: Abusing IE8s XSS Filters [PDF]
Guidance on Internet Explorer XSS Filter